Installing Shiny Days to Program Files possible fix

Now I’m prefacing this with the fact I tested on Windows 10 and it worked, just need someone to test on Windows 8.1 and lower for 100% evidence across all major Windows platforms.

The reason why you can’t save when the game is installed in the Program Files folder is due to permissions. At the very least Windows 10 is affected by this.

What I did was add myself as the owner and as an additional user to the folder then granted myself full control of the “Shiny Days” folder in “Program Files (x86)”. See the following link(s) for information on how to do this. Keep in mind this is the most secure why of doing it as you’re not giving rights permission to all of Program Files, only the Shiny Days folder specifically.

I’ll be happy to assist if anyone has trouble doing this. Once you have set the permissions, go ahead and launch the game. Save to any slot to see if it works.

Again this worked for me on Windows 10. I no longer have any Windows 8 or 7 machines in the house to test, so if someone can, test and post here with the results. Thank you!

We made a post on our dev log about this a week ago

Saving problems can be solved by setting run as administrator or installing to a non 'program files' folder.

Instructions are also included in the IMPORTANT READ ME FIRST pdf file included in the game downloads which is important and should be read first.

I appreciate the link, it was my fault for not being clearer in my opening post. I already knew about the link but I had installed the game by mistake to the Program Files folder. I happened to have my permissions fix due to having the same saving issues with other games and software (VNs and otherwise). I ran my fix instead of uninstalling/reinstalling and it worked.

This is more of an alternative for those who don't want to uninstall/reinstall but could also work as a fix from the get go.

The permissions issue has started to become more of a relevant problem in Windows 10. Its my suggestion to test that if there's any issues installing, saving, or otherwise modifying the contents of an installed program in any way.

I just disable User Account Control. It's more trouble than it's worth. Whenever someone is having weird problems it's usually one of the first troubleshooting tips I give...

I thought the same thing about UAC but disabling in w10 for me didn’t solve it. Good point though.

I recently purchased Shiny Days. And Much like School Days, I have yet to be able to complete a full run in one sitting without the game freezing, crashing, or otherwise. I’m running Windows 10, I’ve change the settings to be compatable with XP(SP3), changed the color settings to 256, set to run as administrator, and nothing works. This game here, I can’t even get much past the 3rd option click in episode 1. It’s even reset to the title screen after selecting Setsuna’s work outfit, or selecting the saved point. What do I do now? Is there a patch out there, do I do any additional settings?

You could wait for the patch that we've all been waiting for for 2.5 months now, or you could take a look at JAST's Shiny Days troubleshooting guide. Or you could ask for a refund, because honestly these problems should've been patched by now.

Here's a beta patch. Give it a shot.